Came here in search of an answer to a problem, but didn't find it? Visit the forum @ LinuxBSDos.com, pick a category and ask a question.

Why is Windows 8 on SSD invisible to Ubuntu 12.10’s installer?

Soon after I got my paws on a Windows 8 Pro installation DVD, I began what I thought would be a simple process of setting up a dual-boot system between it and Ubuntu 12.10 Desktop on an SSD. The SSD is a 2.5″ 128 GB unit from OCZ Technology Group, Inc., which I have already used to dual-boot Windows 7 and older versions of Ubuntu.

The computer I used is the same one I’ve used in the past, a system I assembled using an ASRock motherboard. The board has a UEFI firmware. The process was the same. Install Windows 8 Pro first, then attempt to install Ubuntu 12.10 Desktop alongside it.

Usually, that should not be a problem, but Ubuntu 12.10’s installer could not detect the Windows 8 installation on the SSD. This screen shot shows the disk partitioning methods step of the installation process.
Ubuntu1

Switching to the installer’s Advanced Partitioning Tool does not help, as it clearly reports that the disk does not even have a partition table. I also gave it a shot with the installation DVD of Ubuntu 12.04, with the same result.
Ubuntu2

However, using an installation CD of Fedora 17 gave a different result, as it correctly detected the Windows 8 partitions. In this screen shot, sda1 is the System Reserved partition of Windows 8, while sda2 is the C drive.
Fedora Anaconda Window 8

When I abandoned the SSD and used a regular HDD, everything went as normal and I was able to dual-boot Windows 8 Pro and Ubuntu 12.10 on a 500 GB hard drive. (You may read how I did it in dual-boot Windows 8 and Ubuntu 12.10 on UEFI hardware.) For the record, here are the partitions as seen from inside Windows 8. At this point, I have not been able to figure out why the installers of Ubuntu 12.10 and Ubuntu 12.04 are not able to detect the Windows 8 installation on the SSD.
Win8Partitions

0saves
To have articles like this delivered automatically to your Feed Reader or Inbox, subscribe via RSS or email.
Digital Ocean SSD VPS Cloud Server droplets

Digital Ocean is a VPS/Cloud hosting provider. For just $5 per month, you can get yourself a Cloud server with 512 MB of RAM, 20 GB super-fast SSD, free snapshots, plus backups for a minimal fee. All via a simple graphical interface.

And by signing up with this referral link, you can help support this website.

If you are reading this, your ad could also be occupying this space. Contact us to make it happen.

If commenting on this article is closed, please post your comments at forum.linuxbsdos.com.

26 Comments

  1. Mateus says:

    The same thing happened to me, but i’m using a normal HDD… Someone have any tip?

  2. Bartek Juszczak says:

    Hi, I had the exact same problem with dual booting Ubuntu and Windows on an SSD. Here is the solution to the problem which seemed impossible to solve –

    In the terminal while “booted” from the live CD type “sudo gdisk /dev/sda” (change “/dev/sda” to whatever is appropriate to access your hard disk, if necessary). The program is likely to complain that it’s found both MBR and GPT data, and will ask which to use. It doesn’t matter which you tell it to use.

    At the “Command” prompt, type “x” to enter the experts’ menu.

    At the “Expert command” prompt, type “z” to “zap” (destroy) the GPT data.

    Type “y” in response to the confirmation about destroying the GPT.

    Type “n” in response to the query about blanking the MBR. Caution: If you answer “y” here, you’ll destroy your Windows partition(s)!

    There! Problem solved!

  3. Michael Leones says:

    THe issue is Windows 8 creates a GPT partition which Linux Distros fail to detect. Unless you delete GPT partition, you will face the same issues.

  4. Dani says:

    I am also currently facing the same problem with my regular 500GB HDD, while I currently have Windows 7 and Windows 8 dual-booting on my system.
    Screenshot: http://imageshck.us/photo/my-images/594/screenshotfrom201211200.png/

  5. Rod Smith says:

    Chances are the partition table is damaged. The FixParts program (http://www.rodsbooks.com/fixparts/) may be able to fix the problem.

    Another possibility is that the disk was once used in a RAID array and the partitioner is getting confused by leftover RAID data. This can be erased with a simple Linux command, but I don’t recall what it is, offhand. Perhaps a Web search will turn it up.

    • finid says:

      The SSD was never used in a RAID. It first saw action holding an installation of Windows 7, then was used to dual-boot Windows 7 and Ubuntu 12.04. No issues with those.

      It is only when Windows 8 is on it that Ubuntu fails to detect it.

  6. Kevin Lynch says:

    I’m pretty sure I’ve read something about Windows 8 treating SSD’s differently in some way to get a speed boost. I’m not sure why other distros would work and Ubuntu doesn’t. I don’t bother dual booting any more so I don’t hit these issues.

  7. Dave says:

    May be relevent, I have been having trouble cloning drive with Clonezilla, The extended partion on the master extends off the end of the drive! Gparted see the drive space as unalocated, Possibly Gparted does not see incorect partition tables? Or tables it considers to be incorect.
    The drive had an ext2 boot partition and 4 xfs partitions which were seen by the Ubuntu disk utility.

  8. I think it does more help if you report the problem to Ubuntu Devs rather than blogging here. It is good if you have already reported.

  9. Simple. Ubuntu doesn’t test its installer competently.

    I remember a while back when one of their installers wouldn’t let you out of the manual partition management screen. Which obviously means the installer was not tested AT ALL…

    Truly pathetic QA.

  10. kelisa says:

    The reason is gpart based installer vs non gpart base installer.

    Been there. last time i create hard disk partition with acronis partition utlity forget-the-name. Gparted / ubuntu installer fail to see the partition. Opensuse, mandriva, fedora, have no problem.

    • finid says:

      If it’s just because of gpart/non-gpart, why is it limited to SSD? As I wrote in the article, no such problem on regular HDD. And why is it just with Windows 8? No such problem with Windows 7.

      • Alex says:

        I have the same problem on regular HDD (!) when trying to dual-boot Win8 Pro and Ubuntu 12.04.1 LTS (LinuxMint – the same). Following your recommendations I did many experiments and found the following:
        1. If I install Win8 with UEFI boot enabled in bios, I can’t load from live-USB to install Linux;
        2. If I install Win8 with UEFI boot disabled, I can load from live-USB… just if enable UEFI again. But in this case my HDD become invisible absolutely the same like your SSD.
        3. The only way to place both systems on HDD is to gpart all necessary partitions and install Ubuntu first, before Win8. But in this case the dual-booting with EasyBCD doesn’t work.

Leave a Comment